Xcelerate - Performance Degradation

Incident Report for Xcelerate

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 08:59 PST

Investigating

We're investigating reports of long loading times.
Posted Feb 20, 2026 - 08:48 PST
This incident affected: Xcelerate - Cloud Platform.